Aller au contenu


Photo

PureFTPd Manager


  • Please log in to reply
9 replies to this topic

#1 JollyStone

JollyStone

    Grand(e) bavard(e)

  • Membres
  • PipPipPip
  • 358 Messages :
  • Configuration:iMac 27‘ - i7 - 10.9.2
  • Sexe:Masculin
  • Localisation:Liège

Posté 06 février 2009 - 19:58

Bonjour,

Il y a longtemps que je tente de créer un système FTP sur mon ordinateur mais en vain (problème IP dynamique, routeur Wifi, …).
Je viens de trouvé et d'installer PureFTPd Manager qui fait ça très bien, semble-t-il.
Est-ce que quelqu'un d'entre vous utilise ce système ?
Est-ce fiable, correctement sécurisé ?
Ce que j'ai pu lire sur Internet semble dire que oui mais j'aimerai avoir quelques retours d'utilisateurs.
Et si vous avez quelques astuces et/ou recommandations… Elles sont les bienvenues. :wink2:
iMac 27' • Intel Core i7 • MacOs X.9.2
Mon site personnel : www.jollystone.be

#2 AliGator

AliGator

    (Trop) Grand Bavard

  • Membres d'honneur
  • PipPipPipPipPipPipPipPipPip
  • 12 338 Messages :
  • Configuration:• MacBook Pro 15" 2,2GHz, 10.6
    • MacMini G4 1,42GHz, 10.5
  • Sexe:Masculin
  • Localisation:Rennes (Bretagne, France)
  • Passions:Piano, Cuisine, Danse (Rock, ...), faire des réponses de 3km

Posté 06 février 2009 - 20:05

Je l'ai utilisé pendant longtemps et il est excellent : bien foutu, pas trop compliqué à configurer, interface claire, il fait exactement ce qu'on lui demande... et même plus (possibilité de créer des "dossiers virtuels", de dire qui a le droit d'aller dans quels dossiers de ton disque même si c'est pas dans son "home", etc)...

Donc oui il est bien et bien.
Après il me semblais avoir entendu dire à une époque qu'il n'était pas top compatible avec Léopard à un moment donné. Mais bon c'était p'tet aussi à la sortie de Leopard et il a dû évoluer depuis pour se rendre compatible... Et de toute façon, si ta signature est à jour, il semble que tu aies X.3.9, donc... tu peux foncer :)

Le posteur fou de macfr
Mon blog: Crunchy Development
______________
Devise Shadok : S'il n'y a pas de solution, c'est qu'il n'y a pas de problème...


#3 JollyStone

JollyStone

    Grand(e) bavard(e)

  • Membres
  • PipPipPip
  • 358 Messages :
  • Configuration:iMac 27‘ - i7 - 10.9.2
  • Sexe:Masculin
  • Localisation:Liège

Posté 06 février 2009 - 20:29

Et bien c'est parfait !
Vu que j'éteins rarement mon ordinateur et que je compte laisser ce serveur FTP ouvert en permanence, ça me rassure. Je connais fort peu de chose dans ce domaine. :blush:

Merci Ali. :)
iMac 27' • Intel Core i7 • MacOs X.9.2
Mon site personnel : www.jollystone.be

#4 JollyStone

JollyStone

    Grand(e) bavard(e)

  • Membres
  • PipPipPip
  • 358 Messages :
  • Configuration:iMac 27‘ - i7 - 10.9.2
  • Sexe:Masculin
  • Localisation:Liège

Posté 07 février 2009 - 18:52

Je pensais que ça marcherait tout seul, mais j'ai pourtant quelques petits soucis.

Un ami vient de tester le système. L'accès au répertoire se fait sans problème. J'y ai placé un fichier qu'il sait prendre. Par contre, il ne peut pas rien y déposer.
Message d'erreur :

Impossible de déplacer l'élément "fichier_machin" car "répertoire@adresse_ip" ne peut pas être modifié.

Il me semble que les réglages dans PureFTPd Manager sont correctes. Pourtant, lorsque je vérifie les autorisations sur ce répertoire via les informations du Finder, le propriétaire (ftpvirtual) à un accès en lecture et écriture mais le groupe (ftpgroup) n'a un accès qu'en lecture seule. Impossible de modifier ces droits d'accès car c'est grisé.

Que faire ?

Autre petit problème : le journal ne semble pas s'actualiser. Je n'ai aucune indication du fait que mon ami s'est connecté.

[Édit]
Je comprends ce qu'il se passe…
En vérifiant les préférences de PureFTPd Manager, je constate que le réglage des autorisations d'accès ne s'enregistre pas lorsque l'on ferme la fenêtre des préférences.
Donc, comment contourner ce problème ? Un fichier à éditer ? Lequel ?
[/Édit]

Ce message a été modifié par JollyStone - 07 février 2009 - 20:59 .

iMac 27' • Intel Core i7 • MacOs X.9.2
Mon site personnel : www.jollystone.be

#5 JollyStone

JollyStone

    Grand(e) bavard(e)

  • Membres
  • PipPipPip
  • 358 Messages :
  • Configuration:iMac 27‘ - i7 - 10.9.2
  • Sexe:Masculin
  • Localisation:Liège

Posté 09 février 2009 - 14:17

Bon. Je me suis dit qu'avec le Terminal, il devait être possible de modifier les droits d'accès à ce dossier, même si "Lire les informations" du Finder ne le permettent pas.
Mais voilà… Je n'ai jamais mis les doigts dans cette marmelade. :burp:

J'ai fouillé un peu Internet et ai trouvé comment modifier ces droits d'accès.
Le problème, c'est que je n'arrive pas à le faire.
D'abord, je n'arrivais pas à atteindre le dossier en question, qui se trouve dans Users > ftp > VirtualUsers > (le terminal me plaçant par défaut dans ~ jollystone$)
J'ai compris, Ô merveille, qu'il suffit de faire glisser le dossier sur la fenêtre du terminal pour que le chemin s'affiche tout seul. :up:
Ensuite, je tente de modifier les droits d'accès et c'est là que ça coince : -bash: cd: /Users/VirtualUsers/: No such file or directory
Je suis perdu ! :unsure:

Est-ce qu'un virtuose du Terminal pourrait me donner un coup de main ?

Donc, un dossier "JollyStone" situé dans Users > ftp > VirtualUsers
ayant actuellement les droits : 644 (lecture/écriture - lecture seule - lecture seule)
Devrait avoir les droits : 664 (lecture/écriture - lecture/écriture - lecture seule)
iMac 27' • Intel Core i7 • MacOs X.9.2
Mon site personnel : www.jollystone.be

#6 zekiller28

zekiller28

    Admin qui mord

  • Administrateurs
  • PipPipPipPipPipPipPipPipPip
  • 10 695 Messages :
  • Configuration:Toutes sortes de Mac du PPC à l'Intel et toute sorte de MacOS X De Panther Client à Maverick.
  • Sexe:Masculin
  • Localisation:Saint-Hilarion (78)

Posté 09 février 2009 - 15:28

sudo chmod 664 /Users/ftp/VirtualUsers

Il te demandera de taper ton mot de passe (la saisie ne s'affiche pas à l'écran, c'est normal), valide par le touche [Entrée] de ton clavier et voili…


Si c'est un dossier il faut que tu rajoutes l'option -R après chmod et un slash en fin de ligne soit :

sudo chmod -R 664 /Users/ftp/VirtualUsers/

[Edit] en relisant ton post, je m'aperçois que j'ai la réponse donc voici la ligne qui devrait le faire :

sudo chmod -R 664 /Users/ftp/VirtualUsers/JollyStone/


S'il te dit que le chemin n'est pas bon alors place-toi à la racine de ton disque dur en faisant :
cd /
et ensuite
sudo chmod -R 664 /Users/ftp/VirtualUsers/JollyStone/

Le site de ToolsX
Le site de ToolsXOptimizer

Apple Certified Mac Management Basics 10.12
Apple Certified Mac Management Basics 10.9 English
Apple Certified Mac Integration Basics 10.9 English
Apple Certified Associate Mac Integration 10.8
Apple Certified Mac Management Basics 10.8

#7 JollyStone

JollyStone

    Grand(e) bavard(e)

  • Membres
  • PipPipPip
  • 358 Messages :
  • Configuration:iMac 27‘ - i7 - 10.9.2
  • Sexe:Masculin
  • Localisation:Liège

Posté 09 février 2009 - 16:11

Merci zekiller28.

J'ai bien appliqué cette commande dans le terminal et, en vérifiant via "Lire les informations" du Finder, les droits d'accès sont maintenant corrects.
Par contre, rien n'a changé lors de la connexion FTP, il est toujours impossible de placer un fichier dans ce répertoire.
Les préférences de PureFTPd MAnager n'ont pas changé et indiquent toujours "Lecture seule". <_<

Le problème persiste.
iMac 27' • Intel Core i7 • MacOs X.9.2
Mon site personnel : www.jollystone.be

#8 pascalhs35

pascalhs35

    Membre

  • Membres
  • Pip
  • 1 Messages :
  • Localisation:RENNES

Posté 01 avril 2009 - 19:22

Salue JollyStone

Moi je l'utilse de puis plus de cinq ans sans problème ( dabord sur un EmacG4 et maintenant sur mon Xserve)

Si tu ne peux rien déposer c'est que dans les preférences des parametres ne sont pas bien renseigné.

Quel version de pure ftp manager utilise tu ?

utilise tu la connection annonyme

Si oui donne moi le host name

Si tu l'utilise derrier un routeur il faut parametre celui ci pour un serveur ftp virtuel.

J'attend d'avantage de renseignement de ta part

Pascalhs35

Vat sur ce lien : http://forum.macdk.c...showtopic=16917

Ce message a été modifié par pascalhs35 - 01 avril 2009 - 20:44 .


#9 zekiller28

zekiller28

    Admin qui mord

  • Administrateurs
  • PipPipPipPipPipPipPipPipPip
  • 10 695 Messages :
  • Configuration:Toutes sortes de Mac du PPC à l'Intel et toute sorte de MacOS X De Panther Client à Maverick.
  • Sexe:Masculin
  • Localisation:Saint-Hilarion (78)

Posté 02 avril 2009 - 09:24

Bienvenue sur Macfr pascalhs35 :anniversaire:

C'est dingue le nombre de membres en ce moment qui s'inscrivent pour aider les gens et pas forcément pour poser une question… Bravo à tous ! :anniversaire: :anniversaire: :anniversaire:
Le site de ToolsX
Le site de ToolsXOptimizer

Apple Certified Mac Management Basics 10.12
Apple Certified Mac Management Basics 10.9 English
Apple Certified Mac Integration Basics 10.9 English
Apple Certified Associate Mac Integration 10.8
Apple Certified Mac Management Basics 10.8

#10 JollyStone

JollyStone

    Grand(e) bavard(e)

  • Membres
  • PipPipPip
  • 358 Messages :
  • Configuration:iMac 27‘ - i7 - 10.9.2
  • Sexe:Masculin
  • Localisation:Liège

Posté 13 avril 2009 - 11:36

Bonjour Pascalhs35,

La version que j'utilise est la 1.7
Le compte anonyme a été créé à l'installation puis désactivé via les préférences.
Je suis effectivement derrière un routeur wifi qui est configuré correctement.

Les derniers tests que j'ai pu faire depuis le PC d'un ami étaient bons : up-load et down-load. Mais certaines personnes se retrouvent toujours avec l'interdiction de déposer un fichier dans le répertoire prévu à cet effet. Le plus drôle c'est que moi-même, en me connectant via mon navigateur, je n'ai pas les droits pour déposer un fichier.

Désolé de répondre si tard, j'ai été absent une dizaine de jours.
iMac 27' • Intel Core i7 • MacOs X.9.2
Mon site personnel : www.jollystone.be




1 utilisateur(s) en train de lire ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)