Aller au contenu


Photo

Privilèges base de donnée cPanel


  • Please log in to reply
8 replies to this topic

#1 totosh

totosh

    Tremblez, rebelles.

  • Membres
  • PipPipPipPipPipPipPip
  • 2 210 Messages :
  • Configuration:Macbook Pro 15" 2007
  • Sexe:Masculin
  • Localisation:Orléans (45), France
  • Passions:Nettoyer mon sceptre, donner des coups de bâton, augmenter les impôts...

Posté 28 janvier 2011 - 14:50

Bonjour à tous,

Je souhaite mettre en place un WordPress hébergé sur un site perso. C'est censé être plutôt simple, seulement il m'arrive un problème que je n'explique pas.
Je me connecte au cPanel de mon site, je créé une base de donnée MySQL, je créé également un utilisateur. Je coche tout les privilèges et je valide.
Lorsque je retourne voir les privilèges liés à ce même utilisateur, 4/16 d'entre eux sont décoché (Voir capture d'écran). J'ai beau répéter l'opération, ça ne change rien.
Or, j'ai besoin de tout les privilèges utilisateurs de la base de donnée pour installer WordPress...

J'ai fais des recherches pendant des heures à ce sujet mais aucun n'a l'air d'aborder ce problème.
J'ai bien pensé à une connexion en tant que Root à mon cPanel mais je ne suis même pas sûr que ce soit possible. J'en ai parlé a mon hébergeur mais il n'a rien trouvé de mieux que de me redonner mon identifiants de connexion de base.

Bref, je ne sais plus trop quoi faire... Si vous avez une piste, je suis preneur les amis !
Merci d'avance.

#2 jp

jp

    Touriste

  • Modérateurs
  • PipPipPipPipPipPipPipPipPip
  • 6 564 Messages :
  • Configuration:N/A
  • Sexe:Masculin
  • Localisation:Créteil

Posté 28 janvier 2011 - 16:35

Il te dit quoi WordPress avec ces droits là ? (P.-S. : les accents dans les URL, c'est mal :D)
La phrase suivante est fausse. La phrase précédente est vraie.

#3 zekiller28

zekiller28

    Admin qui mord

  • Administrateurs
  • PipPipPipPipPipPipPipPipPip
  • 10 642 Messages :
  • Configuration:Toutes sortes de Mac du PPC à l'Intel et toute sorte de MacOS X De Panther Client à Maverick.
  • Sexe:Masculin
  • Localisation:Saint-Hilarion (78)

Posté 28 janvier 2011 - 18:05

(P.-S. : les accents dans les URL, c'est mal :D)

Je confirme ! :rolleyes:
Le site de ToolsX
Le site de ToolsXOptimizer

Apple Certified Mac Management Basics 10.12
Apple Certified Mac Management Basics 10.9 English
Apple Certified Mac Integration Basics 10.9 English
Apple Certified Associate Mac Integration 10.8
Apple Certified Mac Management Basics 10.8

#4 totosh

totosh

    Tremblez, rebelles.

  • Membres
  • PipPipPipPipPipPipPip
  • 2 210 Messages :
  • Configuration:Macbook Pro 15" 2007
  • Sexe:Masculin
  • Localisation:Orléans (45), France
  • Passions:Nettoyer mon sceptre, donner des coups de bâton, augmenter les impôts...

Posté 28 janvier 2011 - 19:27

Il te dit quoi WordPress avec ces droits là ? (P.-S. : les accents dans les URL, c'est mal :D)

Dans quelle URL ?

- Sinon, j'entre mes infos de base de donnée, il à l'air de les accepter puisque il m'affiche ceci :
Image IPB

Message qui n'est bien sûr pas affiché lorsque j'entre des mauvaises informations.


- En cliquant sur "Lancer l'installation", voici le message affiché :
Image IPB


#5 jp

jp

    Touriste

  • Modérateurs
  • PipPipPipPipPipPipPipPipPip
  • 6 564 Messages :
  • Configuration:N/A
  • Sexe:Masculin
  • Localisation:Créteil

Posté 28 janvier 2011 - 19:45

Dans l'URL de l'image. Ça passe avec FireFox mais pas Safari.

Et tu es sûr que tes identifiants / base de données sont bons ? Si tu as moyens de te connecter à ta base sans cPanel (genre avec PHPMyAdmin), tu es bloqué aussi sur toute tentative d'action ?

Je dis ça parce que ça m'étonnerait que les privilèges que tu n'arrives pas à mettre influencent l'installation de WordPress (m'étonnerais qu'il utilise des vues...).
La phrase suivante est fausse. La phrase précédente est vraie.

#6 totosh

totosh

    Tremblez, rebelles.

  • Membres
  • PipPipPipPipPipPipPip
  • 2 210 Messages :
  • Configuration:Macbook Pro 15" 2007
  • Sexe:Masculin
  • Localisation:Orléans (45), France
  • Passions:Nettoyer mon sceptre, donner des coups de bâton, augmenter les impôts...

Posté 28 janvier 2011 - 20:30

Dans l'URL de l'image. Ça passe avec FireFox mais pas Safari.

Et tu es sûr que tes identifiants / base de données sont bons ? Si tu as moyens de te connecter à ta base sans cPanel (genre avec PHPMyAdmin), tu es bloqué aussi sur toute tentative d'action ?

Je dis ça parce que ça m'étonnerait que les privilèges que tu n'arrives pas à mettre influencent l'installation de WordPress (m'étonnerais qu'il utilise des vues...).

Ok pour l'URL de l'image, le soucis viens de CloudApp, qui génère stock mes image et génère une adresse aléatoire. Je ferai gaffe la prochaine fois.
- Malheureusement, je suis sûr que mes identifiants sont bon, j'ai dû réessayer une bonne vingtaine de fois et le message n'est pas le même quand j'entre des identifiants faux.

- Si j'utilise PHPMyAdmin depuis cPanel alors j'imagine que c'est idiot ?

- D'après la doc de Wordpress :
« Créez une base de données MySql pour WordPress sur votre serveur Web (avec tous les privilèges en accès et en modification). »

Je pense qu'il doit utiliser tout les privilèges du coup, non ?

Ce message a été modifié par totosh - 28 janvier 2011 - 20:30 .


#7 totosh

totosh

    Tremblez, rebelles.

  • Membres
  • PipPipPipPipPipPipPip
  • 2 210 Messages :
  • Configuration:Macbook Pro 15" 2007
  • Sexe:Masculin
  • Localisation:Orléans (45), France
  • Passions:Nettoyer mon sceptre, donner des coups de bâton, augmenter les impôts...

Posté 28 janvier 2011 - 23:26

Finalement j'ai réussi en modifiant le fichier à la main plutôt qu'en passant par l'assistant WordPress.
Merci pour votre aide, merci JP ! Image IPB

#8 jp

jp

    Touriste

  • Modérateurs
  • PipPipPipPipPipPipPipPipPip
  • 6 564 Messages :
  • Configuration:N/A
  • Sexe:Masculin
  • Localisation:Créteil

Posté 28 janvier 2011 - 23:41

Cool :)

Et c'était quoi alors ? Un caractère à la con dans le mot de passe qui passais pas via l'interface ? Les droits MySQL qui n'étaient vraiment pas bon (mais en quoi ça a corrigé le problème de passer par le fichier de conf dans ce cas ?) ?
La phrase suivante est fausse. La phrase précédente est vraie.

#9 totosh

totosh

    Tremblez, rebelles.

  • Membres
  • PipPipPipPipPipPipPip
  • 2 210 Messages :
  • Configuration:Macbook Pro 15" 2007
  • Sexe:Masculin
  • Localisation:Orléans (45), France
  • Passions:Nettoyer mon sceptre, donner des coups de bâton, augmenter les impôts...

Posté 01 février 2011 - 20:58

Cool :)

Et c'était quoi alors ? Un caractère à la con dans le mot de passe qui passais pas via l'interface ? Les droits MySQL qui n'étaient vraiment pas bon (mais en quoi ça a corrigé le problème de passer par le fichier de conf dans ce cas ?) ?

Les droits MySQL étaient les bons à priori même si l'interface affichait le contraire.
Et bizarrement, l'Interface d'installation de WordPress ne modifiait pas tous les champs du fichier wp-config.php.




1 utilisateur(s) en train de lire ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)