Aller au contenu


Photo

Accès serveur FTP très lent


  • Please log in to reply
6 replies to this topic

#1 pauljohn

pauljohn

    Membre

  • Membres
  • Pip
  • 44 Messages :

Posté 09 février 2010 - 15:37

Bonjour à tous,

J'ai installé un serveur FTP sur le Mac Mini (Snow Leopard) de la boîte où je bosse (avec votre aide, merci...).

Le problème, c'est que depuis quelque temps l'accès au serveur depuis un poste extérieur est très lent.

En fait, la connexion se fait mais Cyberduck (pour ne citer que lui) passe un temps fou sur "Obtention de la liste des fichiers du répertoire" (à tel point que nos clients nous disent qu'ils n'ont pas pu se connecter à notre serveur).

Ensuite, quand on choisit de rapatrier un fichier du serveur, il se passe encore un temps très long avant que le téléchargement commence.

Si vous avez un avis sur la question, je suis preneur.

Merci d'avance.

Ce message a été modifié par pauljohn - 09 février 2010 - 16:10 .


#2 BorakLeRouge

BorakLeRouge

    Hamster d'or (dort ?)

  • Membres
  • PipPipPipPipPipPipPip
  • 3 949 Messages :
  • Configuration:Mac Mini Core i7 - 16Go - 2To Hybride
  • Sexe:Masculin
  • Localisation:Cormeilles en Parisis.rb
  • Passions:Macintosh, Photo, Haute-fidélité, Ski, Roller, Call of Duty, Tactical Ops, Counter Strike, Worms 1

Posté 09 février 2010 - 16:33

Il ne passe pas en mode veille ?

Je fais mes sauvegardes sur NSA-Cloud !

Au bout de 10 ans, le vieux MacPro vient de laisser sa place à un MacMini i7...


#3 jp

jp

    Touriste

  • Modérateurs
  • PipPipPipPipPipPipPipPipPip
  • 6 564 Messages :
  • Configuration:N/A
  • Sexe:Masculin
  • Localisation:Créteil

Posté 09 février 2010 - 17:06

J'avais eu le problème avec le serveur de FTP de Mac OS X Server : des connexions très lentes, des requêtes de rapatriement très lent (que ce soit un fichier ou une liste de fichier : même chose), alors qu'une fois la requête effectuée, le débit est à son maximum.
Et donc, Cyberduck faisait des TimeOut, et Transmition tenait bon, mais patinait...

Je n'ai jamais trouvé la raison à ça : sur certains serveurs, ça fonctionnait très bien, alors que sur d'autres, pas du tout. Peut-être un problème de configuration réseau (genre l'établissement du mode passif, un NAT qui à du mal, un reverse DNS erroné que le serveur FTP tenterait de vérifier, que sais-je !).

Je sais pas si c'est le même problème, mais si quelqu'un connais la raison et la solution, je suis preneur aussi !
La phrase suivante est fausse. La phrase précédente est vraie.

#4 AliGator

AliGator

    (Trop) Grand Bavard

  • Membres d'honneur
  • PipPipPipPipPipPipPipPipPip
  • 12 338 Messages :
  • Configuration:• MacBook Pro 15" 2,2GHz, 10.6
    • MacMini G4 1,42GHz, 10.5
  • Sexe:Masculin
  • Localisation:Rennes (Bretagne, France)
  • Passions:Piano, Cuisine, Danse (Rock, ...), faire des réponses de 3km

Posté 09 février 2010 - 17:18

Et dans le réseau local, c'est le même souci ou c'est plus rapide ?

Le posteur fou de macfr
Mon blog: Crunchy Development
______________
Devise Shadok : S'il n'y a pas de solution, c'est qu'il n'y a pas de problème...


#5 pauljohn

pauljohn

    Membre

  • Membres
  • Pip
  • 44 Messages :

Posté 09 février 2010 - 17:59

Le réseau fonctionne très bien. Je ne sais pas si ça peut aider mais quand je me connecte au serveur avec Cyberduck à partir d'un poste connecté au même réseau que le mac serveur, ça se fait quasi instantanément.

#6 AliGator

AliGator

    (Trop) Grand Bavard

  • Membres d'honneur
  • PipPipPipPipPipPipPipPipPip
  • 12 338 Messages :
  • Configuration:• MacBook Pro 15" 2,2GHz, 10.6
    • MacMini G4 1,42GHz, 10.5
  • Sexe:Masculin
  • Localisation:Rennes (Bretagne, France)
  • Passions:Piano, Cuisine, Danse (Rock, ...), faire des réponses de 3km

Posté 09 février 2010 - 21:47

Ca serait pas donc au niveau du routeur (enfin de la passerelle quoi et de la redirection des ports etc) que ça ralentirait, si tu n'as le cas que quand tu accèdes de l'extérieur ?

Le posteur fou de macfr
Mon blog: Crunchy Development
______________
Devise Shadok : S'il n'y a pas de solution, c'est qu'il n'y a pas de problème...


#7 jp

jp

    Touriste

  • Modérateurs
  • PipPipPipPipPipPipPipPipPip
  • 6 564 Messages :
  • Configuration:N/A
  • Sexe:Masculin
  • Localisation:Créteil

Posté 09 février 2010 - 21:51

Est ce que tu as la possibilité de tester avec un serveur FTP tiers (genre PureFTPd) : moi, de suite, ça fonctionnais beaucoup mieux.

Ça solutionne pas vraiment le problème, mais ça permet au moins de le caractériser.
La phrase suivante est fausse. La phrase précédente est vraie.




0 utilisateur(s) en train de lire ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)