Aller au contenu

Messages recommandés

Bonsoir,

 

j'ai essayé de créer un alias avec apache d'un dossier

j'ai ajouté la ligne suivante dans le httpd.conf

 

ligne :

Alias "/nomAlias" "/Users/y../chemin_de_mon_dossier"

 

mais quand j'essaye d'accèder à l'adresse : http://127.0.0.1/nomAlias

je reçois le message suivant :

Forbidden

 

You don't have permission to access /nomAlias/ on this server.

 

faut il ajouter autre chose ?

 

Merci

Lien à poster
Partager sur d’autres sites
Que disent les droits sur cet alias et son original ?

 

les droits sont bons, mais je crois que tu as confondu l'alias DNS ( je sais pas si je peux l'appeler ainsi ) avec me serveur web apache, et l'alias ou link qu'on peut créer avec la commande unix ln?

 

( désolé peut être mon message n'était pas claire aussi )

 

Merci

Lien à poster
Partager sur d’autres sites
Forbidden

 

You don't have permission to access /nomAlias/ on this server.

C'est un message que délivre apache. Les droits d'accès ne sont pas bon dans le finder ou dans apache.

Que dit error.log d'apache ?

 

Essaye de mettre un max de permissions à ton dossier (chmod 777) pour voir si ça vient de là.

Ou alors modifie le fichier de conf d'apache en ajoutant une directive du genre :

<Directory "/Users/y../chemin_de_mon_dossier">
AllowOverride All
</Directory>

Lien à poster
Partager sur d’autres sites
C'est un message que délivre apache. Les droits d'accès ne sont pas bon dans le finder ou dans apache.

Que dit error.log d'apache ?

 

Essaye de mettre un max de permissions à ton dossier (chmod 777) pour voir si ça vient de là.

Ou alors modifie le fichier de conf d'apache en ajoutant une directive du genre :

<Directory "/Users/y../chemin_de_mon_dossier">
AllowOverride All
</Directory>

 

Merci idr pr ta reponse, on fait j'ai tout essayé avec mais rien, j'ai fait comme il est décris dans la doc officielle mais rien, toujours le même message,

 

voilà le code que j'ai ajouté :

 

Alias /doc /Users/youssef/Documents

<Directory /Users/youssef/Documents>
order deny,allow
deny from all
allow from localhost, 127.0.0.1
Options Indexes FollowSymLinks
</Directory>

 

NB : j ai essayé de mettre juste AllowOverride All , de mettre les path des dossier entre " ou ' mais toujours le même message.

 

y a t il par hasard une autre valeur à changer ?

Lien à poster
Partager sur d’autres sites
  • 3 weeks later...

Bonjour à tous

 

j'ai pu enfinr résoudre ce problème, il était question de droit d'accès de l'utilisateur apache au dossier pour qui je voulais créer un Alias

il suffisait de donner des droits X er R sur le dossier cible et des R sur tous les dossier parents de ce dernier.

 

NB : l'utilisateur apache est : _www

 

salut

Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement
×
×
  • Créer...